
Colorado Department of Transportation   Page 89

LAB 5 - Horizontal Alignments

Although there are multiple methods for creating horizontal geometry in InRoads, this lab will concentrate on 
the using the horizontal curve set commands and importing geometry from graphics. Additional methods 
covered in the Geometry for ROW course include cogo and traverse commands.

This lab also demonstrates how to modify an existing alignment and create a parallel alignment to an existing 
alignment. An example of this would be to create parallel/offset alignment from a road centerline to represent 
the edge of road or other feature that parallels the centerline.

Chapter Objectives:

 Create a new geometry

 Create alignment tangents

 Understand the difference between Named and Unnamed cogo points and how to apply 
cogo point names 

 Define alignment curves

 Define and modify alignment stationing

 Annotate an alignment

 Create a horizontal alignment from graphics

 Modify an existing alignment

 Create parallel horizontal alignments

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345_Horizontal Alignments.dgn

 C:\Projects\12345\ROW_Survey\InRoads\Geometry\12345SURV_Fieldbook.alg

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

A typical workflow is:

1. Create or open a geometry project

2. Create horizontal alignments

3. Assign stationing for alignments

4. Define station equations, if any

5. Define alignment key-points (unique points of interest)

6. Review alignments

7. View created alignments

8. Display stationing for alignments

9. Annotate created alignments

Note: The screened topography and the training guides are either locked graphics or in an 
attached reference file, you will not be able to delete these graphics and will use them 
for orientation.
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Lab 5.1 - Name Alignment Points

Section Objectives:

♦ Add names to unnamed points on an alignment

1. Start InRoads opening the file 12345DES_Horizontal Alignments.dgn from the 
C:\Projects\12345\Design\Drawings\Reference_Files\ directory.

2. Select File > Project Options from the InRoads main menu and review the settings in the 
Geometry tab.

Note: If Point Name During Edits is set to Assign on the Geometry tab of the Options 
dialog box, alignment key-points are generated with a name based on the next 
available ID as specified in the Seed Point Name field.   The specified seed point 
name can be alpha, numeric, or alphanumeric characters. The assigned name is 
also reserved in the Cogo buffer. However the point is not written to the Cogo 
Buffer automatically.

For descriptions of each of the items in the Geometry tab, refer to the Practical 
Guide for Using InRoads.
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3. Load the geometry project 12345DES_Design.alg from the folder 
C:\Projects\12345\Design\InRoads\.

Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states:

♦ Unnamed

♦ Named

♦ Cogo Points

4. Review the horizontal alignment and notice that many points on the alignment are not 
named.
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In the next series of steps, the alignment points are named and added to the Cogo buffer.

5. Select Geometry > Horizontal Curve Set > Events.

6. In the Horizontal Events dialog box, toggle on Alignment Point to Cogo in the Add As 
section.

7. Key in 200 for the Seed Name:. 

8. Proposed Alignment for Description:.

9. Select ALG_PRO for the Style:.

10. Click Apply.

A Results dialog box appears with the new point name and the associated coordinates of 
the point. All alignment key points that were not previously assigned a name are written to 
the Cogo buffer beginning with the ID number of 200.
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Note: The command Geometry > Utilities > Assign Names can also be used to add, 
delete, or rename geometry points. However, names added using this command are 
not added to the Cogo Buffer.

11. Close the Results and Horizontal Events dialog boxes.

Lab 5.2 - Create New Geometry

Next we will create a new geometry project and a placeholder for horizontal alignment data.

Section Objectives:

♦ Create a geometry project and place holders for horizontal geometry data.

1. From the InRoads main menu File > New.

 

2. <D> the Geometry tab.

3. For the Type, select Geometry Project.

4. In the Name field, key in 12345_Geometry Training.
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5. In the Description field, key in Geometry Training class.

Note: The lower portion of the New dialog displays geometry projects that are currently 
loaded.

6. <D> Apply (Do not Close the New dialog box yet). This creates the geometry project 
where all new alignment data for this class will be stored. At this point, it is held in RAM 
(Random Access Memory). 

7. Verify that the new geometry project was created.

8. Use the following data to create a place holder for horizontal geometry data.

♦ Type: Horizontal Alignment
♦ Name: Design Alt 1
♦ Description: Alignment by PI method
♦ Style: ALG_PRO
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♦ Curve Definition: ARC

9. <D> the Apply then the Close buttons.

10. Verify the horizontal alignment is created in the active geometry project.

11. <R> on the 12345_Geometry Training geometry project in the InRoads Explorer pane 
and <D> Save from the right click menu.

12. Verify that the directory path is set to C:\Projects\12345\Design\InRoads.

13. Key in 12345_Geometry Training for the File name.

14. <D> Save then Cancel to save the file and dismiss the Save As dialog box.

The following exercises will step you through creating an alignment using the Horizontal 
Curve Set, or PI method. While these exercises are based on a roadway alignment, the tools and 
logic apply to any new alignment whether it is for drainage, utilities, pavement marking, bridge 
geometry, parcels, or any other purpose. 
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Lab 5.3 - Create Alignment Tangents

Section Objectives:

♦ Create horizontal alignments from PI to PI. 

1. From the MicroStation pull-down menu select Utilities > Saved Views.

2. From the Saved Views dialog box <D> saved view name SH 86 ALT 1.

3. <D> the Apply button.

Points A-M represent the required location of alignment PI’s. 

Horizontal curve set commands will be used to create the horizontal alignment. The next 
series of steps are used to construct the tangents.
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4. Before beginning, verify that the Design Alt 1 alignment is Active. Any geometry data 
entered will be added to this alignment.

5. To clear the MicroStation view, toggle Off the Reference Display for the 
12345SURV_Topo100Scale01.dgn in the References dialog box.

6. Select Geometry > Horizontal Curve Set > Add PI from the Inroads main menu. You 
are prompted in the MicroStation status bar to Identify Alignment End.

Note: There is not a dialog box for this command.
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7. <T> then <D> at point A (tentative or snap, and Data point). The alignment interactively 
displays as you move the cursor.

8. Repeat step 7 for points B through M.

9. <R> (reset) when complete.

10. If the alignment created does not pass through points A-M, use the Insert, Move, or Delete 
PI commands from the Horizontal Curve Set tools to correct the locations.
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11. Review the new alignment using Geometry > Review Horizontal

Following is a summary of the PI locations

Note: Results may vary based on the specific PI locations defined by the user.

Lab 5.4 - Define Alignment Curves

The Define Horizontal Curve Set command is used to create curves between alignment 
tangents or to revise existing curve definition. The Previous and Next buttons are used to step 
sequentially through the alignment. The Select button can be used to graphically identify an 
alignment location for editing. As alignment components are selected, they highlight in the 
MicroStation view. 

Section Objectives:

♦ Add curves to horizontal alignments using various methods

♦ Use the Curve Calculator to determine the radius of a curve

PI NORTHING EASTING BEARING DISTANCE STA.
A  1,558,417.74  3,267,409.40 0+00.00
B  1,558,457.06  3,268,756.14  N 88°19'39.62” E  1,347.31' 13+47.30
C  1,558,469.66  3,270,669.73  N 89°37'21.60” E  1,913.63' 32+60.94
D  1,558,050.59  3,272,645.47  S 78°01'28.88” E  2,019.69' 52+80.63
E  1,556,982.55  3,276,540.43  S 74°39'56.80” E  4,038.75' 93+19.38
F  1,556,716.98  3,277,527.47  S 74°56'25.98” E  1,022.14' 103+41.51
G  1,555,931.76  3,280,408.64  S 74°45'18.96” E  2,986.25' 133+27.77
H  1,555,939.60  3,282,135.29  N 89°44'23.81” E  1,726.67' 150+54.44
I  1,555,699.32  3,283,343.64  S 78°45'12.06” E  1,232.01' 162+86.44
J  1,554,474.27  3,288,508.48  S 76°39'23.63” E  5,308.14' 215+94.58
K  1,553,821.34  3,290,431.45  S 71°14'44.01” E  2,030.79' 236+25.37
L  1,553,315.19  3,291,416.57  S 62°48'22.55” E  1,107.55' 247+32.92
M  1,553,346.54  3,293,367.43  N 89°04'46.05” E  1,951.11' 266+84.03
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1. Select Geometry > Horizontal Curve Set > Define Curve. The first two tangents A-
B and B-C highlight.

2. Key in Radius 1: 21120.

3. <D> the Apply button. The curve is created and displays.

4. <D> the Next button. Tangents B-C and C-D highlight.

5. Key in Radius 1: 3000.

6. <D> the Apply button.

7. Repeat steps 4-6 for the curves at locations:

D Radius = 11,000.00
E   Radius = 3,000.00
F   Radius = 3,000.00
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For the first 5 curves, radii were input to define the curves. For the curve located at point G, the 
degree of curve is the known component (along with the external deflection angle). The Curve 
Calc… button is used to solve the curve data.

8. <D> the Next button to define the curve at point G.

9. <D> the Curve Calc… button.

10. Set Compute: to Simple Curve.

The calculation is based on a 5 degree 30 minute 17 second curve.

11. Toggle on DOC: and key in 5 30 07. 

12. Verify that the Angle field is toggled on.

13. <D> Compute.
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Notice the changes that occur in the dialog box. The values in the unlocked fields are 
modified based on the locked fields.
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14. <D> OK. The Curve Calculator dialog box is dismissed and the calculated radius is added 
to the Radius 1 field in the parent dialog box.

15. <D> Apply and the curve will be created.

The next curve (location H) will also be calculated using the degree-of-curve. However a short-
cut will be used to generate the input for the Radius 1 field.
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16. <D> Next to select the tangents on either side of point H.

17. In the Radius 1: Field Key in D 2-23-14. The key in stands for D.O.C. 2^ 23' 14".

18. Press the keyboard <TAB> key to leave the field. The radius (2400.10) will compute for the 
selected location.

19. <D> Apply to form the curve.

20. If time permits, complete the remainder of the curves using the data listed below:
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I   Radius = 15,000.00
J   Radius =   5,000.00
K Radius = 3,000.00
L   DOC = 3-34-52

21. Review the alignment data select Geometry > Review Horizontal.

Lab 5.5 - Alignment Stationing

Section Objectives:

♦ Change the assigned stationing of an alignment.

The default station value assigned to the start of a new alignment is 0+00. Redefine the 
beginning station to 100+00.00

1. Select Geometry > Horizontal Curve Set > Stationing.

2. In the Stationing dialog box, key in 100+00. (Can be entered as 10000 and then tab out 
of the field) in the Starting Station field.

3. <D> the Apply button.

4. Verify your results using both of these methods:

♦ Geometry > Review Horizontal
♦ Tools > Tracking > Horizontal Alignments
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5. Select Geometry > View Geometry > Stationing from the InRoads main menu.

6. <D> the Preferences button.

7. Highlight the Proposed-100 Ft Interval preference.

8. <D> Load and Close.
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9. <D> the Apply button from the View Stationing dialog box. Stationing is displayed.

10. Experiment with changing the global scale factor value for text and redisplaying the 
stationing.

Lab 5.6 - Annotating an Alignment

Section Objectives:

♦ Annotate an alignment.
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1. Select Geometry > View Geometry > Horizontal Annotation from the InRoads 
main menu.

2. Verify the settings as shown above and click Apply to display the alignment annotation.
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3. Review the results in MicroStation.

Challenge Exercise:

1. Use Geometry>Copy Geometry to copy alignment Design ALT 1 to a new 
horizontal alignment named Design ALT 1 Modified.

2. Perform the following actions to the copied alignment:

♦ Move a PI

♦ Redefine one or more horizontal curves

♦ Define alignment stationing to end at station 382+00

♦ Redisplay stationing at a 500 foot interval

♦ Introduce 2 station equations; one overlap and one gap.

♦ Revert the alignment to a simple PI at point B (remove the curve definition)

♦ Transpose the direction of the alignment

Lab 5.7 - Horizontal Alignment from Graphics

Alignments can be created from existing MicroStation graphics. In this exercise a chained 
MicroStation element will be used to create an alignment.

Section Objectives:

♦ Create a new horizontal alignment from MicroStation graphics.

1. From the MicroStation pull-down menu select Utilities > Saved Views.
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2. From the Saved Views dialog box, highlight Holder Driveway.

3. <D> the Apply button then Close.

4. Select File > Import > Geometry. The Import Geometry dialog box will open.

5. Fill in the following information on the From Graphics tab:

6. Set the Type: to Horizontal Alignment

7. Key in Holder Driveway for the Name:.

8. Key in Driveway at Sta 190+80 RT for the Description:.
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9. Set the Style: to ALG_SECONDARY.

10. Verify the Geometry Project: is set to 1234_Geometry Training.

11. <D> the Apply button. The Import Geometry dialog box is minimized.

12. You are prompted to Identify Element. <D> on the MicroStation graphic drawn in the 
center of the driveway.

13. <D> again to accept the highlighted graphics in the MicroStation view.

14. <R> in the MicroStation view to terminate the command. The Import Geometry dialog 
box is redisplayed. The MicroStation graphics have been imported as an alignment.

Note: The geometry name field increments for additional selection(s).

15. <D> the Close button to dismiss the Import Geometry dialog box.
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16. Verify the alignment was created.

17. Review the alignment using Geometry > Review Horizontal.

18. When finished Close the Review Horizontal Alignment dialog box.

19. Time permitting, display the alignment graphics, stationing, and curve information.

Lab 5.8 - Extend Alignment

The alignment Holder Driveway does not intersect the reference line alignment Design Alt 1. 
Standard practice necessitates the driveway alignment to commence at the main-line reference 
line.

Section Objectives:

♦ Learn one of the tools used to modify existing alignments.

1. Select Geometry > Utilities > and hold.
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Note: If the commands for Trim and Extend Alignment are not listed in the menu, this 
means that they are not enabled. These 2 commands are an extension of the 
Horizontal & Vertical Elements command set which must be enabled.

2. Select Tools > Application ADD-Ins.

3. Enable Horizontal and Vertical Elements Add-In.
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4. Once enabled, Select Geometry > Utilities > Extend Alignment.

5. At the prompt: Identify Alignment to extend to, <D> on the alignment Design Alt 1.

6. At the prompt: Identify Alignment to extend, <D> on the alignment Holder Driveway.

7. <D> to accept the presented solution.

Note: The alignment-alignment intersection is now the initial point of the driveway 
alignment. Because the alignment was edited (extended) from its beginning, the 
initial station value was recalculated to -0+12.41. Because the original beginning 
point retains its station value (0+00), the new beginning point is given a negative 
station value.

8. From the InRoads main menu, select Geometry > Horizontal Curve Set > Stationing 
define the driveway beginning station as 3+25.
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Challenge Exercises:

♦ Display stationing at a 100 foot interval for Holder Drive.

♦ Display alignment annotation for Holder Drive.

♦ Recall saved view Drive @ 180+00.

♦ Import the graphics representing the driveway centerline into an alignment named 
Drive 180+00.

♦ Use the command Geometry > Utilities > Trim Alignment to remove the portion 
of the driveway alignment that lies north of the main-line reference line.

Note: The order selecting alignments is not important when using the trim alignment 
command. The location of the data point in response to Identify portion to clip 
determines both the alignment and the portion of that alignment that is eliminated.

Lab 5.9 - Saving Geometry

Alignments cannot be saved individually. They are saved when the geometry project is saved. 
Due to the fact InRoads works on geometry that is loaded in memory, the geometry project 
must be saved at appropriate times.

Section Objectives:

♦ Save InRoads design data.

1. From the InRoads main menu, select File > Save > Geometry Project. The Save As 
dialog box is displayed with the Save as type: set to Geometry (*.alg).

2. Verify you are in the correct project directory; C:\Projects\12345\Design\InRoads.
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3. The file name should match the Active: name at the bottom of the Save As dialog box. If 
necessary, use Active drop-down menu and reselect the desired name to ensure the saved 
file name will match the geometry project name.

Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an.ALG extension. To minimize any 
confusion between these two names, ensure that the saved Geometry name in the 
project folder matches the Geometry name displayed in InRoads explorer.

4. <D> the Save button and then the Cancel button. The file will be saved to disk and the 
Save As dialog is dismissed.

Lab 5.10 - Creating Parallel Horizontal Alignments

Offset alignments can be created to generate geometry for elements such as right-of-way limits, 
easement limits, under-drains, retaining walls, bridge decks, etc.

Section Objectives:

♦ Learn additional tools for creating alignments.

In this lab horizontal alignments are created to define the right-of-way limits for the mainline 
road and the side road. The Side Road has a right-of-way width of 60’ (30’ on each side of 
centerline). The mainline alignment has a total right-of-way width of 150’; 50’ feet north of the 
reference line and 100’ south. At the intersection of the right-of-way lines a radius of 15’ is 
required.

The workflow will consist of using an assortment of geometry commands:
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♦ Copying Geometry - used to combine geometry residing in two different geometry 
projects into one project

♦ Multi-Center Curve – to create radius returns

♦ Parallel Horizontal Alignment - to offset alignments

♦ Join Alignments – to connect separate alignments

♦ Join Elements – to simplify geometry

The first step is to create alignments relative to both the mainline alignment (SH 86) and the 
side road alignment (Side Road). These two horizontal alignments reside in two different 
geometry projects. To work efficiently, they should reside in a single geometry project. The 
Copy Geometry command is used to achieve this result.

1. Select Geometry>Copy Geometry from the Inroads main menu.

2. In the From area, select 12345_Design for the geometry project.

3. Highlight the alignment Side Road from list.

4. Verify that Include All Children is toggled on.

5. In the To area, Select 12345_Geometry Training for the Geometry Project.

6. Key in Side Road for the Horizontal Alignment name.

7. Key in Side Road Alignment for the Description.

8. Select ALG_PRO for the Style.
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9. <D> Apply then Close to copy the alignment and dismiss the dialog box.

10. Verify the alignment was copied.

11. Copy alignment SH 86 as SH 86 ALT 1 if you feel the mainline alignment created in an 
earlier lab exercise may contain errors
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12. Set the geometry project 12345_Geometry Training as Active.

The next step is to generate the radius returns. This is done by using the Multicenter Curve 
command. Begin by creating the radius returns north of the mainline alignment.

13. From the Saved Views dialog box, <D> saved view name Side Road.

14. Click Apply.

15. Select Geometry > Utilities > MultiCenter Curve from the InRoads main menu.

16. Select One Center.

17. Input the following values:

♦ Radius: 15
♦ Width 1: 30
♦ Width 2: 50
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18. <D> the Apply button. The following prompts are displayed.

19. In the MicroStation view <D> on the Side Road alignment.

20. <D> on the Design ALT 1 alignment.

21. <D> in the Northwest quadrant

22. <D> to accept and create an alignment representing the radius return.

23. To add the radius returns to the remaining quadrants, <D> in the quadrant then <D> again 
to Accept.

New alignments will be assigned names based on the seed alignment name specified in 
Tools > Options [Geometry].
Two new alignments are created, 1and 2.
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Note: Your stationing graphics may appear at a different location than shown above.

The next steps will be to offset the mainline and side road alignments so they match up with the 
returns that were just created. This is done using the Parallel Horizontal Alignment command.

24. From the MicroStation drop-down menu, select Utilities > Keyin. The key in window is 
needed to input the desired station limits and offset distances.

Note: Stations and offsets can be identified graphically. However, using key-in's provides 
greater accuracy.

25. From the InRoads main menu select Geometry > Utilities > Parallel Horizontal 
Alignment....

26. In the Parallel Horizontal Alignment dialog box, toggle on Interactive By Station 

27. <D> the Apply button.

28. In the MicroStation view <D> on the mainline alignment.

29. At the prompt Identify First Station/Key in Station, key in 224+00 in the MicroStation 
Key-in window.

30. Press the Enter key.

31. At the prompt Identify Second Station/Key in Station, key in 224+93.20 in the 
MicroStation Key-in window.
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32. Press the Enter key.

33. For Identify Location: key in -50 (50’ to the left) in the MicroStation Key-in window.

34. Press the Enter key.

35.  <D> the in the view window to accept the solution. Alignment 3 is created and displayed.

36. Repeat the Geometry > Utilities > Parallel Horizontal by Station command to the 
east of the side road using the following data:

♦ Station limits of: 225+86.76 to 227+00, 50’ left of Design Alt 1

Alignment 4 is created and displayed.
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37. Repeat the process to create the alignments along the Side Road north of the radius returns.

Next use the Join Alignment command to connect the alignments created in the previous steps 
single alignments for each quadrant. 

Join alignments 3, 1, & 5 to create the Northwest quadrant’s right-of-way limits.

38. Select Geometry > Utilities > Join.

39. toggle on Delete Original Alignments. 

Note: The first alignment identified (3) will become the final alignment name and 
alignments (1) and (5) will be deleted upon completion of the command.

40.  <D> the Apply button and follow the prompts.

41. <D> on alignment 3.

42. <D> alignment 1.
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43. <D> on alignment 5.

44. <D> to accept the results.

45. Reset <R> <R> to exit the command.

Alignment 3 is now the combination of the alignments 3, 1, and 5. Alignments 1 and 5 have 
been removed from the geometry project.
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46. Review alignment 3.

47. Using the same steps above, join alignments 6, 2, and 4 (in that order) to create the 
northeast quadrant’s right-of-way limits; begin with alignment 6.

Once the above step is completed, alignments 3 and 6 define the right-of-way limits on the 
north side of the intersection.

Another method of creating parallel alignments is by element instead of by station.

48. Select Geometry > Utilities > Parallel Horizontal Alignment.
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Parallel Horizontal Alignment by Element differs from by Station in that you can select the 
limits of the alignment to offset by selecting alignment components (tangents or curves) to 
define the desired limits.


